Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Engine cutting out during hard acceleration.

  1. #1

    Default Engine cutting out during hard acceleration.

    Looking for help identifying possible causes. Car cuts out during hard acceleration. Feels like you are hitting a hard revlimiter. Searching forum, I changed the spark plugs with NGK tr6 gapped to .028". Still does it, and now even stumbles occasionally during normal driving. Feels to me like the ignition is cutting out for a split second. Looking at the collective experience for guidance.
    Thanks
    Eric

  2. Default

    Fuel pressure? Check the fuel filter?

    is this a long term issue (ecu tune?). Something that just started?

  3. #3

    Default

    This is something new. Doesn't do it when I drive softly.a It feels electrical, because the power cuts out very abruptly for a split second then power comes back for a split second and repeat. I push in clutch and get off gas and car stops bucking.

  4. Default

    Check the Coil packs to look for a bad one. Get an ohm meter and compare all the values at the terminals. Check your wiring to the coil packs as well by checking ohms on each terminal. I found a short in one of my coil wires by this method when I had the same cutting out under WOT. You can also decrease your plug gap to 0.025". Good luck.

  5. #5
    Join Date
    Aug 2011
    Location
    SoCal
    Posts
    404
    Rep Power
    8

    Default

    Coils rarely fail. Plugs first, wiring second to check. Boost kills spark.

  6. #6

    Default

    What are your coil gaps? .026 - .028 for boosted engines.

  7. Default

    Coil gap or spark plug gap?

  8. #8

    Default

    spark plug

  9. #9
    Join Date
    Jun 2011
    Location
    NJ USA
    Posts
    17
    Rep Power
    0

    Default

    Quote Originally Posted by Supercar Sensation View Post
    Check the Coil packs to look for a bad one. Get an ohm meter and compare all the values at the terminals. Check your wiring to the coil packs as well by checking ohms on each terminal. I found a short in one of my coil wires by this method when I had the same cutting out under WOT. You can also decrease your plug gap to 0.025". Good luck.
    I had the same problem , 3 of the coil packs were different manufacture ( they were not defective ) , but the car would buck under hard acceleration.

  10. #10

    Default

    Figured I'd let everyone know what the ultimate outcome was. It was a failing fuel pump.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •