Results 1 to 2 of 2

Thread: Fuel pump?

  1. #1

    Default Fuel pump?

    Hi Everyone! My car has been acting a little strange lately and seemed to have lost much of its power. Last night we put it on a dyno and it is reporting only 300hp, we checked for boost and vacuum leaks but everything checked out. One of the sensors they used reported it running extremely lean. We pulled the fuel filter and there are metal shavings in it and under pressure the pump was pretty erratic about the pressure it was sending fuel. So now I have a few questions for you.

    1. Anyone know the model number of the fuel pump? We are trying to get it out now but I am hoping I can find it locally if possible to get this back on the road.
    2. Have any of you experienced a similar problem?

    I have been looking at the dyno reports over the last few years and it seems there is definitely a problem here. Any thoughts on what else it could be? The ECU was flashed by Willy for me almost 2 years ago and it ran great until I had to replace the battery.

  2. #2
    Join Date
    Oct 2006
    Location
    Tallahassee
    Posts
    469
    Rep Power
    13

    Default

    yea
    sounds like a ground or power supply problem
    please do fuel pump relay upgrade
    as well;
    install an 044 Bosch fuel pump new lines and gauges.
    the low voltage will destroy the stock fuel pump.
    if you have data; please send it
    Thanks, Troy
    -Troy Fralick
    troy@nobleupgrades.com
    Tallahassee Speed Shop, Inc.
    5338 Gateway Drive
    Tallahassee, Fl 32303
    850-597-8919
    904-838-9150 cell
    And
    Remade by Hand, Inc.
    Porsche Restorations
    173 McCallister Rd
    Crawfordville, FL 32327

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •