Results 1 to 3 of 3

Thread: Alternator idiot light on with ignition off

  1. #1

    Default Alternator idiot light on with ignition off

    I'm back from the dead with a troubleshooting request.

    Symptoms:
    The Alt idiot light glows weakly with the ignition off (key in my pocket). It goes dark with the ignition on and engine off, and it stays dark with the engine running.

    Original theory:

    Probably a fault in the voltage regulator part of the alternator, so I installed a new one. The Alt idiot light is still on with the ignition off. The idiot light still goes dark with the ignition on (both with the engine not running and with the engine running).

    Troubleshooting steps:
    The new alternator is still installed, and I have now removed every fuse from the interior fuse box and from the engine compartment fuse box. The Alt idiot light is still on.
    With the fuses still pulled, I remove the 3-wire connector from the alternator. Idiot light still on.
    I removed the relay that controls the interior lights. Idiot light still on.

    FWIW:
    I have not done any work behind the center console panel that houses the idiot lights. I've never had that panel off.

    I measured current draw at the battery positive terminal with the ignition off. There is a spike to about 1 amp as soon as I connect the meter, but it quickly dies down to about 0.004 amp.

    Thinking that I would just put up with the idiot light malfunction, I connected a "smart" trickle charger. A few hours later I discovered that the alternator was hot to the touch. I don't know if that always happens with trickle chargers (I never checked before), or if the hot alternator is a result of the electrical gremlin I'm chasing.

    So:
    Any suggestions on what troubleshooting step to try next?
    TIA!
    -------------------------
    Jeff
    Noble parts for sale, see my Noble website: http://Noblecars.org

  2. #2

    Default

    Warm alternator usually indicates internal short. Pull B+ (charge wire to battery) and check for continuity from B+ stud back to alternator housing. Spin tester we use at our NAPA store will identify this condition.

  3. #3

    Default

    I did more troubleshooting this afternoon, and the gremlin ran away, at least for now. I had already pulled all the fuses, including maxifuses, the interior light relay, and the 3-pin connector on the alternator. After posting, I removed the 3 wires attached to the alternator output (B+ stud), and the idiot light went out. Then I connected each of those 3 wires, one at a time, back to the B+ stud. The idiot light stayed dark. I reinstalled all the fuses, and the idiot light stayed dark. I got the key and turned the ignition on, and the idiot light illuminated. Ignition off, and the idiot light went out.

    I started the engine with my logging laptop hooked up and the alternator output was in the 14.2 - 14.4 volt neighborhood. So everything is as it should be. I didn't "fix" anything. Go figure. Maybe I should buy a lottery ticket!
    -------------------------
    Jeff
    Noble parts for sale, see my Noble website: http://Noblecars.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •