Results 1 to 2 of 2

Thread: Clicking from the engine

  1. #1
    Join Date
    Mar 2005
    Location
    Michigan
    Posts
    75
    Rep Power
    14

    Default Clicking from the engine

    Summerized the car today. Had to change the battery because the combined drain from the alarm and the electronic security system on the radio exceeded the trickle charger For all of you without trickle chargers, get one ASAP since changing the battery is a royal PITA.

    Started the car and a loud ticking came from the engine, sounded like a stuck lifter. Turned off the car and proceeded to change the serpentine belt (slipping like crazy last year and was glazed), change plugs, and change the oil. Started the car up and no clicking so I thought all was well. Drove the car 30 feet and another loud clicking. Sounds like mechanical tap. Couldn't tell exactly where it was coming from but it sounded like it was coming from the belt. Before changing the belt, I had made sure the exact position especially on the alternator since it has a 9 rib pulley while everything is 6 rib. Noticed that it was one rib from the inside so I put the other one there. When I examined the new belt, noticed that it had started to slip off the 6 rib pulleys. I then put it back on but this time, put it all of the way in on the alternator and NO more tapping noice. So if you notice funny tapping from the car but it comes from the area around the serpentine belt, check the position.

    Tim

  2. #2
    Join Date
    Dec 2004
    Posts
    5,515
    Rep Power
    29

    Default

    Quote Originally Posted by jorligan View Post
    Summerized the car today. Had to change the battery because the combined drain from the alarm and the electronic security system on the radio exceeded the trickle charger For all of you without trickle chargers, get one ASAP since changing the battery is a royal PITA.

    Started the car and a loud ticking came from the engine, sounded like a stuck lifter. Turned off the car and proceeded to change the serpentine belt (slipping like crazy last year and was glazed), change plugs, and change the oil. Started the car up and no clicking so I thought all was well. Drove the car 30 feet and another loud clicking. Sounds like mechanical tap. Couldn't tell exactly where it was coming from but it sounded like it was coming from the belt. Before changing the belt, I had made sure the exact position especially on the alternator since it has a 9 rib pulley while everything is 6 rib. Noticed that it was one rib from the inside so I put the other one there. When I examined the new belt, noticed that it had started to slip off the 6 rib pulleys. I then put it back on but this time, put it all of the way in on the alternator and NO more tapping noice. So if you notice funny tapping from the car but it comes from the area around the serpentine belt, check the position.

    Tim
    Thanks for the tip, Tim.

    I also just had to remove my battery to put the new fuel pump wires in. It is a bit awkward and heavy to work in and out while removing/installing the cables and the bottom support bar, isn't it?

    Do you have the built-in battery charger that 1G supplies as an option? I haven't had any problem with that one maintaining a charge.

    You should join us at Baker's on Sunday afternoons this year. Bring the NSX too.

    Craig

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •